You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

119 lines
4.0KB

  1. [ignore]
  2. ; We fork some components by platform
  3. .*/*[.]android.js
  4. ; Ignore unexpected extra "@providesModule"
  5. .*/node_modules/.*/node_modules/fbjs/.*
  6. node_modules/react-native/Libraries/react-native/React.js
  7. ; Ignore duplicate module providers
  8. ; For RN Apps installed via npm, "Libraries" folder is inside
  9. ; "node_modules/react-native" but in the source repo it is in the root
  10. node_modules/react-native/Libraries/react-native/React.js
  11. ; Flow doesn't support platforms
  12. .*/Libraries/Utilities/LoadingView.js
  13. ; Ignore polyfills
  14. node_modules/react-native/Libraries/polyfills/.*
  15. ; These should not be required directly
  16. ; require from fbjs/lib instead: require('fbjs/lib/warning')
  17. node_modules/warning/.*
  18. ; Flow doesn't support platforms
  19. .*/Libraries/Utilities/HMRLoadingView.js
  20. [untyped]
  21. .*/node_modules/@react-native-community/cli/.*/.*
  22. ; Ignore packages in node_modules which we (i.e. the jitsi-meet project) have
  23. ; seen to cause errors and we have chosen not to fix.
  24. .*/node_modules/@atlaskit/.*/*.js.flow
  25. .*/node_modules/react-native-keep-awake/.*
  26. .*/node_modules/react-native-permissions/.*
  27. .*/node_modules/styled-components/.*
  28. .*/\.git/.*
  29. [include]
  30. [libs]
  31. node_modules/react-native/Libraries/react-native/react-native-interface.js
  32. node_modules/react-native/flow/
  33. [options]
  34. emoji=true
  35. esproposal.optional_chaining=enable
  36. esproposal.nullish_coalescing=enable
  37. ; We (i.e. the jitsi-meet project) are using the haste module system on Web as
  38. ; well, not only on React Native. Unfortunately, Flow does not support .web.js
  39. ; by default. Override Flow's defaults to include .web.js as well. Technically,
  40. ; we have .native.js as well so the choice of .web.js may lead to errors.
  41. ; Practically though, it is a potential future problem that we do not have at
  42. ; the time of this writing.
  43. module.file_ext=.web.js
  44. ; Flow's defaults:
  45. module.file_ext=.js
  46. module.file_ext=.json
  47. module.file_ext=.ios.js
  48. module.system=haste
  49. module.system.haste.use_name_reducers=true
  50. # get basename
  51. module.system.haste.name_reducers='^.*/\([a-zA-Z0-9$_.-]+\.js\(\.flow\)?\)$' -> '\1'
  52. # strip .js or .js.flow suffix
  53. module.system.haste.name_reducers='^\(.*\)\.js\(\.flow\)?$' -> '\1'
  54. # strip .ios suffix
  55. module.system.haste.name_reducers='^\(.*\)\.ios$' -> '\1'
  56. module.system.haste.name_reducers='^\(.*\)\.android$' -> '\1'
  57. module.system.haste.name_reducers='^\(.*\)\.native$' -> '\1'
  58. module.system.haste.paths.blacklist=.*/__tests__/.*
  59. module.system.haste.paths.blacklist=.*/__mocks__/.*
  60. module.system.haste.paths.whitelist=<PROJECT_ROOT>/node_modules/react-native/Libraries/.*
  61. module.system.haste.paths.whitelist=<PROJECT_ROOT>/node_modules/react-native/RNTester/.*
  62. module.system.haste.paths.whitelist=<PROJECT_ROOT>/node_modules/react-native/IntegrationTests/.*
  63. module.system.haste.paths.blacklist=<PROJECT_ROOT>/node_modules/react-native/Libraries/react-native/react-native-implementation.js
  64. module.system.haste.paths.blacklist=<PROJECT_ROOT>/node_modules/react-native/Libraries/Animated/src/polyfills/.*
  65. munge_underscores=true
  66. module.name_mapper='^[./a-zA-Z0-9$_-]+\.\(bmp\|gif\|jpg\|jpeg\|png\|psd\|svg\|webp\|m4v\|mov\|mp4\|mpeg\|mpg\|webm\|aac\|aiff\|caf\|m4a\|mp3\|wav\|html\|pdf\)$' -> 'RelativeImageStub'
  67. suppress_type=$FlowIssue
  68. suppress_type=$FlowFixMe
  69. suppress_type=$FlowFixMeProps
  70. suppress_type=$FlowFixMeState
  71. suppress_comment=\\(.\\|\n\\)*\\$FlowFixMe\\($\\|[^(]\\|(\\(<VERSION>\\)? *\\(site=[a-z,_]*react_native\\(_ios\\)?_\\(oss\\|fb\\)[a-z,_]*\\)?)\\)
  72. suppress_comment=\\(.\\|\n\\)*\\$FlowIssue\\((\\(<VERSION>\\)? *\\(site=[a-z,_]*react_native\\(_ios\\)?_\\(oss\\|fb\\)[a-z,_]*\\)?)\\)?:? #[0-9]+
  73. suppress_comment=\\(.\\|\n\\)*\\$FlowExpectedError
  74. [lints]
  75. sketchy-null-number=warn
  76. sketchy-null-mixed=warn
  77. sketchy-number=warn
  78. untyped-type-import=warn
  79. nonstrict-import=warn
  80. deprecated-type=warn
  81. unsafe-getters-setters=warn
  82. inexact-spread=warn
  83. unnecessary-invariant=warn
  84. signature-verification-failure=warn
  85. deprecated-utility=error
  86. [strict]
  87. deprecated-type
  88. nonstrict-import
  89. sketchy-null
  90. unclear-type
  91. unsafe-getters-setters
  92. untyped-import
  93. untyped-type-import
  94. [version]
  95. ^0.104.0